Create new single factor model

Home Forums Onyx Helpdesk Create new single factor model

This topic contains 3 replies, has 2 voices, and was last updated by  Maike 2 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #813

    Maike
    Participant

    I have a problem with the “Create new single factor model”-function: I tested this function using and old dataset I analysed some time ago using R (so for which I know the results). Even after deleting the constant variable and settig the mean structure to saturated I did not get the same results as with R. However, drawing the model in onyx on my own works perfectly and leads to my old results.
    When I compare the lavaan-scripts (created with onyx) there is no difference between the two models (after deleting the constant variable and setting the mean structure to saturated). But comparing the estimation summary shows the problem: The observed statistics differ for the two models…55 for the self-drawn model and 65 for the model created with the function (without the constant).
    Can you help me finding my mistake?

    Thanks,
    Maike

    #815

    admin
    Keymaster

    Maike,

    thanks for letting us know about this.

    Likely, you have encountered a bug in Onyx. From the values you report, I guess that you 10 observed variables? In this case, Onyx gets confused about the presence/absence of the mean structure or, I believe, does counting the dfs in a faulty way. We will check asap.

    Thanks,
    Andreas

    #819

    admin
    Keymaster

    The problem is fixed now. Please download the latest Onyx version (at least V1.0-1010). Thanks again for reporting this problem!

    #823

    Maike
    Participant

    Hello Andreas,

    thank you for the prompt reply and for fixing the problem so quickly!

    Kind regards,
    Maike

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in